CVE-2025-5263: Error handling for script execution was incorrectly isolated from web content
Error handling for script execution was incorrectly isolated from web content, which could have allowed cross-origin leak attacks.
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Fixed in 115.24 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Fixed in 139 - Upgrade
Upgrade
ubuntu/thunderbirdto a version that resolves this vulnerability.Fixed in 1:128.12.0+build1-0ubuntu0.22.04.1 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Fixed in 128.11 - Upgrade
Upgrade
debian/firefoxto a version that resolves this vulnerability.Fixed in 159.0.1-1 - Upgrade
Upgrade
debian/firefox-esrto a version that resolves this vulnerability.Fixed in 140.12.0esr-1~deb12u1Fixed in 153.6.0esr-1~deb12u2Fixed in 140.15.0esr-1~deb13u1Fixed in 153.6.0esr-1~deb13u1Fixed in 153.5.1esr-1Fixed in 153.6.0esr-1 - Upgrade
Upgrade
debian/thunderbirdto a version that resolves this vulnerability.Fixed in 1:140.12.0esr-1~deb12u1Fixed in 1:153.6.0esr-1~deb12u2Fixed in 1:140.12.0esr-1~deb13u1Fixed in 1:153.6.0esr-1~deb13u1Fixed in 1:153.5.0esr-1Fixed in 1:153.6.0esr-1 - Upgrade
Upgrade
Firefoxto a version that resolves this vulnerability.Fixed in 139 - Upgrade
Upgrade
Firefox ESRto a version that resolves this vulnerability.Fixed in 115.24 - Upgrade
Upgrade
Firefox ESRto a version that resolves this vulnerability.Fixed in 128.11 - Upgrade
Upgrade
Thunderbirdto a version that resolves this vulnerability.Fixed in 139 - Upgrade
Upgrade
Thunderbirdto a version that resolves this vulnerability.Fixed in 128.11
Event History
Parent advisories
This vulnerability appears in the following advisories.
Peer vulnerabilities
Found alongside the following vulnerabilities.
Frequently Asked Questions
What is the severity of CVE-2025-5263?
CVE-2025-5263 is considered a high-severity vulnerability due to its potential to allow cross-origin leak attacks.
How do I fix CVE-2025-5263?
To fix CVE-2025-5263, update Mozilla Firefox to version 139 or Firefox ESR to version 128.11 or higher.
Which versions of Firefox are affected by CVE-2025-5263?
CVE-2025-5263 affects Firefox versions prior to 139 and Firefox ESR versions prior to 115.24 and 128.11.
Can CVE-2025-5263 lead to data breaches?
Yes, due to its ability to facilitate cross-origin leak attacks, CVE-2025-5263 can potentially lead to data breaches.
Is there a workaround for CVE-2025-5263?
There are no known workarounds for CVE-2025-5263; the recommended action is to update to the latest version.