CVE-2025-5266: Script element events leaked cross-origin resource status
Script elements loading cross-origin resources generated load and error events which leaked information enabling XS-Leaks attacks. This vulnerability was fixed in Firefox 139, Firefox ESR 128.11, Thunderbird 139, and Thunderbird 128.11.
Other sources
Script elements loading cross-origin resources generated load and error events which leaked information enabling XS-Leaks attacks. This vulnerability affects Firefox < 139 and Firefox ESR < 128.11.
— Red Hat
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Fixed in 139 - Upgrade
Upgrade
ubuntu/thunderbirdto a version that resolves this vulnerability.Fixed in 1:128.12.0+build1-0ubuntu0.22.04.1 - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Fixed in 128.11 - Upgrade
Upgrade
debian/firefoxto a version that resolves this vulnerability.Fixed in 159.0.1-1 - Upgrade
Upgrade
debian/firefox-esrto a version that resolves this vulnerability.Fixed in 140.12.0esr-1~deb12u1Fixed in 153.6.0esr-1~deb12u2Fixed in 140.15.0esr-1~deb13u1Fixed in 153.6.0esr-1~deb13u1Fixed in 153.5.1esr-1Fixed in 153.6.0esr-1 - Upgrade
Upgrade
debian/thunderbirdto a version that resolves this vulnerability.Fixed in 1:140.12.0esr-1~deb12u1Fixed in 1:153.6.0esr-1~deb12u2Fixed in 1:140.12.0esr-1~deb13u1Fixed in 1:153.6.0esr-1~deb13u1Fixed in 1:153.5.0esr-1Fixed in 1:153.6.0esr-1 - Upgrade
Upgrade
Firefoxto a version that resolves this vulnerability.Fixed in 139 - Upgrade
Upgrade
Firefox ESRto a version that resolves this vulnerability.Fixed in 128.11 - Upgrade
Upgrade
Thunderbirdto a version that resolves this vulnerability.Fixed in 139 - Upgrade
Upgrade
Thunderbirdto a version that resolves this vulnerability.Fixed in 128.11
Event History
Parent advisories
This vulnerability appears in the following advisories.
Peer vulnerabilities
Found alongside the following vulnerabilities.
Frequently Asked Questions
What is the severity of CVE-2025-5266?
The severity of CVE-2025-5266 is classified as moderate due to its potential to enable XS-Leaks attacks.
How do I fix CVE-2025-5266?
To fix CVE-2025-5266, update Mozilla Firefox to version 139 or Firefox ESR to version 128.11.
Which versions of Firefox are affected by CVE-2025-5266?
CVE-2025-5266 affects versions of Firefox prior to 139 and Firefox ESR prior to 128.11.
What kind of attacks can CVE-2025-5266 enable?
CVE-2025-5266 can enable XS-Leaks attacks by leaking information through load and error events from cross-origin resources.
Is user interaction required for CVE-2025-5266 to be exploited?
No, CVE-2025-5266 can be exploited without user interaction, highlighting its significance.