CVE-2025-5267: Clickjacking vulnerability could have led to leaking saved payment card details

Published May 27, 2025
·
Updated

A clickjacking vulnerability could have been used to trick a user into leaking saved payment card details to a malicious page. This vulnerability was fixed in Firefox 139, Firefox ESR 128.11, Thunderbird 139, and Thunderbird 128.11.

Other sources

A clickjacking vulnerability could have been used to trick a user into leaking saved payment card details to a malicious page. This vulnerability affects Firefox < 139 and Firefox ESR < 128.11.

— Red Hat

Affected Software

21 affected componentsFixes available
Mozilla Firefox<139
Mozilla Firefox ESR<128.11
Mozilla Thunderbird<139
139
Mozilla Firefox<128.11.0
Mozilla Firefox<139.0
ubuntu/mozjs52*
ubuntu/mozjs38*
ubuntu/mozjs68*
ubuntu/mozjs52*
ubuntu/mozjs102*
ubuntu/mozjs78*
ubuntu/mozjs91*
ubuntu/thunderbird<1:128.12.0+build1-0ubuntu0.22.04.1
1:128.12.0+build1-0ubuntu0.22.04.1
ubuntu/mozjs102*
ubuntu/mozjs115*
Mozilla Firefox ESR<128.11
128.11
Mozilla Firefox<139
139
Mozilla Thunderbird<128.11
128.11
debian/firefox
159.0.1-1
debian/firefox-esr
140.12.0esr-1~deb12u1153.6.0esr-1~deb12u2140.15.0esr-1~deb13u1153.6.0esr-1~deb13u1153.5.1esr-1153.6.0esr-1
debian/thunderbird
1:140.12.0esr-1~deb12u11:153.6.0esr-1~deb12u21:140.12.0esr-1~deb13u11:153.6.0esr-1~deb13u11:153.5.0esr-11:153.6.0esr-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 139
  2. Upgrade

    Upgrade ubuntu/thunderbird to a version that resolves this vulnerability.

    Fixed in 1:128.12.0+build1-0ubuntu0.22.04.1
  3. Upgrade

    Upgrade to a fixed release to a version that resolves this vulnerability.

    Fixed in 128.11
  4. Upgrade

    Upgrade debian/firefox to a version that resolves this vulnerability.

    Fixed in 159.0.1-1
  5. Upgrade

    Upgrade debian/firefox-esr to a version that resolves this vulnerability.

    Fixed in 140.12.0esr-1~deb12u1Fixed in 153.6.0esr-1~deb12u2Fixed in 140.15.0esr-1~deb13u1Fixed in 153.6.0esr-1~deb13u1Fixed in 153.5.1esr-1Fixed in 153.6.0esr-1
  6. Upgrade

    Upgrade debian/thunderbird to a version that resolves this vulnerability.

    Fixed in 1:140.12.0esr-1~deb12u1Fixed in 1:153.6.0esr-1~deb12u2Fixed in 1:140.12.0esr-1~deb13u1Fixed in 1:153.6.0esr-1~deb13u1Fixed in 1:153.5.0esr-1Fixed in 1:153.6.0esr-1
  7. Upgrade

    Upgrade Firefox to a version that resolves this vulnerability.

    Fixed in 139
  8. Upgrade

    Upgrade Firefox ESR to a version that resolves this vulnerability.

    Fixed in 128.11
  9. Upgrade

    Upgrade Thunderbird to a version that resolves this vulnerability.

    Fixed in 139
  10. Upgrade

    Upgrade Thunderbird to a version that resolves this vulnerability.

    Fixed in 128.11

Event History

May 27, 2025
CVE Published
via Mozilla·12:00 AM
Data Sourced
via Mozilla·12:00 AM
DescriptionSeverityAffected Software
Data Sourced
via Ubuntu·12:00 AM
RemedyDescriptionSeverityAffected Software
CVE Published
via MITRE·12:29 PM
Data Sourced
via MITRE·12:29 PM
Description
Data Sourced
via Red Hat·01:01 PM
DescriptionSeverityAffected Software
Data Sourced
via OSV·01:15 PM
DescriptionSeverityAffected Software
Data Sourced
via NVD·01:15 PM
DescriptionSeverityWeaknessAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Frequently Asked Questions

1

What is the severity of CVE-2025-5267?

CVE-2025-5267 is classified as a high severity vulnerability due to its potential to expose sensitive payment card details.

2

How do I fix CVE-2025-5267?

To fix CVE-2025-5267, update Firefox to version 139 or Firefox ESR to version 128.11 or later.

3

What types of software are affected by CVE-2025-5267?

CVE-2025-5267 affects Mozilla Firefox versions earlier than 139 and Mozilla Firefox ESR versions earlier than 128.11.

4

What does CVE-2025-5267 exploit?

CVE-2025-5267 exploits a clickjacking vulnerability to trick users into leaking their saved payment card information.

5

Are there any workarounds for CVE-2025-5267?

There are no effective workarounds for CVE-2025-5267, so updating to a secure version is strongly recommended.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203