cifs-utils through 6.14, with verbose logging, can cause an information leak when a file contains = (equal sign) characters but is not a valid credentials file.
In cifs-utils through 6.14, a stack-based buffer overflow when parsing the mount.cifs ip= command-line argument could lead to local attackers gaining root privileges.
cifs-utils 7.9 fixes a mount-option injection vulnerability in mount.cifs that can allow local privilege escalation in affected privileged mounting configurations.
Affected versions: cifs-utils-4.2 - cifs-utils-7.8
Users are recommended to upgrade to version cifs-utils 7.9, which fixes the issue. Distributors can alternatively backport the fixes.
Credit: Johnathan Benge (reporter) Paulo Alcantara (patch author)
cifs-utils 7.9 release: webpage: https://wiki.samba.org/index.php/LinuxCIFSutils tarball: https://download.samba.org/pub/linux-cifs/cifs-utils/ git: git://git.samba.org/cifs-utils.git gitweb: http://git.samba.org/?p=cifs-utils.git;a=summary