USN-7183-1: linux, linux-lts-xenial vulnerabilities
Andy Nguyen discovered that the Bluetooth L2CAP implementation in the Linux kernel contained a type-confusion error. A physically proximate remote attacker could use this to cause a denial of service (system crash) or possibly execute arbitrary code. (CVE-2020-12351)
Andy Nguyen discovered that the Bluetooth A2MP implementation in the Linux kernel did not properly initialize memory in some situations. A physically proximate remote attacker could use this to expose sensitive information (kernel memory). (CVE-2020-12352)
Andy Nguyen discovered that the Bluetooth HCI event packet parser in the Linux kernel did not properly handle event advertisements of certain sizes, leading to a heap-based buffer overflow. A physically proximate remote attacker could use this to cause a denial of service (system crash) or possibly execute arbitrary code. (CVE-2020-24490)
Ziming Zhang discovered that the VMware Virtual GPU DRM driver in the Linux kernel contained an integer overflow vulnerability. A local attacker could use this to cause a denial of service (system crash). (CVE-2022-36402)
Zheng Wang discovered a use-after-free in the Renesas Ethernet AVB driver in the Linux kernel during device removal. A privileged attacker could use this to cause a denial of service (system crash). (CVE-2023-35827)
Several security issues were discovered in the Linux kernel. An attacker could possibly use these to compromise the system. This update corrects flaws in the following subsystems: - GPU drivers; - I2C subsystem; - Network drivers; - Pin controllers subsystem; - TTY drivers; - USB Mass Storage drivers; - Framebuffer layer; - Ext4 file system; - File systems infrastructure; - Bluetooth subsystem; - Kernel init infrastructure; - DMA mapping infrastructure; - Memory management; - 9P file system network protocol; - IPv4 networking; - IPv6 networking; - Logical Link layer; - MAC80211 subsystem; - Netfilter; - NFC subsystem; - Phonet protocol; - Network traffic control; - Wireless networking; (CVE-2024-44947, CVE-2023-52594, CVE-2024-35886, CVE-2024-38633, CVE-2023-52509, CVE-2024-26625, CVE-2024-36946, CVE-2024-45021, CVE-2024-36270, CVE-2021-47118, CVE-2024-43884, CVE-2024-36941, CVE-2024-38619, CVE-2021-47501, CVE-2024-49967, CVE-2024-42090, CVE-2024-40912, CVE-2024-36968, CVE-2024-53057, CVE-2023-52507, CVE-2024-42101, CVE-2021-47086, CVE-2024-42153, CVE-2024-40959, CVE-2024-26777, CVE-2024-44944, CVE-2024-43856, CVE-2024-39301)
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
ubuntu/linux-lts-xenialto a version that resolves this vulnerability.Fixed in 4.4.0-262.296~14.04.1 - Upgrade
Upgrade
ubuntu/linuxto a version that resolves this vulnerability.Fixed in 4.4.0-262.296 - Upgrade
Upgrade
ubuntu/linux-image-4.4.0-262-genericto a version that resolves this vulnerability.Fixed in Ubuntu Pro - Upgrade
Upgrade
ubuntu/linux-image-4.4.0-262-lowlatencyto a version that resolves this vulnerability.Fixed in Ubuntu Pro - Upgrade
Upgrade
ubuntu/linux-image-genericto a version that resolves this vulnerability.Fixed in Ubuntu Pro - Upgrade
Upgrade
ubuntu/linux-image-generic-lts-xenialto a version that resolves this vulnerability.Fixed in Ubuntu Pro - Upgrade
Upgrade
ubuntu/linux-image-lowlatencyto a version that resolves this vulnerability.Fixed in Ubuntu Pro - Upgrade
Upgrade
ubuntu/linux-image-lowlatency-lts-xenialto a version that resolves this vulnerability.Fixed in Ubuntu Pro - Upgrade
Upgrade
ubuntu/linux-image-virtualto a version that resolves this vulnerability.Fixed in Ubuntu Pro - Upgrade
Upgrade
ubuntu/linux-image-virtual-lts-xenialto a version that resolves this vulnerability.Fixed in Ubuntu Pro - Upgrade
Upgrade to a fixed release to a version that resolves this vulnerability.
Patch USN-7183-1
Event History
Child vulnerabilities
Contains the following vulnerabilities.
- CVE-2020-12351
- CVE-2020-12352
- CVE-2020-24490
- CVE-2021-47086
- CVE-2021-47118
- CVE-2021-47501
- CVE-2022-36402
- CVE-2023-35827
- CVE-2023-52507
- CVE-2023-52509
- CVE-2023-52594
- CVE-2024-26625
- CVE-2024-26777
- CVE-2024-35886
- CVE-2024-36270
- CVE-2024-36941
- CVE-2024-36946
- CVE-2024-36968
- CVE-2024-38619
- CVE-2024-38633
- CVE-2024-39301
- CVE-2024-40912
- CVE-2024-40959
- CVE-2024-42090
- CVE-2024-42101
- CVE-2024-42153
- CVE-2024-43856
- CVE-2024-43884
- CVE-2024-44944
- CVE-2024-44947
- CVE-2024-45021
- CVE-2024-49967
- CVE-2024-53057
- UBUNTU-CVE-2020-12351
- UBUNTU-CVE-2020-12352
- UBUNTU-CVE-2020-24490
- UBUNTU-CVE-2021-47086
- UBUNTU-CVE-2021-47118
- UBUNTU-CVE-2021-47501
- UBUNTU-CVE-2022-36402
- UBUNTU-CVE-2023-35827
- UBUNTU-CVE-2023-52507
- UBUNTU-CVE-2023-52509
- UBUNTU-CVE-2023-52594
- UBUNTU-CVE-2024-26625
- UBUNTU-CVE-2024-26777
- UBUNTU-CVE-2024-35886
- UBUNTU-CVE-2024-36270
- UBUNTU-CVE-2024-36941
- UBUNTU-CVE-2024-36946
- UBUNTU-CVE-2024-36968
- UBUNTU-CVE-2024-38619
- UBUNTU-CVE-2024-38633
- UBUNTU-CVE-2024-39301
- UBUNTU-CVE-2024-40912
- UBUNTU-CVE-2024-40959
- UBUNTU-CVE-2024-42090
- UBUNTU-CVE-2024-42101
- UBUNTU-CVE-2024-42153
- UBUNTU-CVE-2024-43856
- UBUNTU-CVE-2024-43884
- UBUNTU-CVE-2024-44944
- UBUNTU-CVE-2024-44947
- UBUNTU-CVE-2024-45021
- UBUNTU-CVE-2024-49967
- UBUNTU-CVE-2024-53057
Frequently Asked Questions
What is the severity of USN-7183-1?
USN-7183-1 has a high severity due to the potential for remote code execution and denial of service.
How do I fix USN-7183-1?
To fix USN-7183-1, update your Linux kernel to version 4.4.0-262.296 or later.
What systems are affected by USN-7183-1?
USN-7183-1 affects Ubuntu 16.04 and 14.04 systems running specific Linux kernel versions.
What is CVE-2020-12351 related to USN-7183-1?
CVE-2020-12351 details a type-confusion vulnerability in the Bluetooth L2CAP implementation that can lead to system crashes or arbitrary code execution.
Can USN-7183-1 be exploited remotely?
Yes, USN-7183-1 can be exploited by a physically proximate attacker, making it critical to address promptly.