CVE-2022-0102: Type Confusion in V8

Published Oct 14, 2021
·
Updated

Type confusion in V8 in Google Chrome prior to 97.0.4692.71 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page.

Credit

Brendon Tiszka

Affected Software

18 affected componentsFixes available
Google Chrome<97.0.4692.71
97.0.4692.71
Google Chrome<97.0.4692.71
Fedoraproject Fedora=34
Fedoraproject Fedora=35
Fedoraproject Fedora=36
alpine/qt5-qtwebengine<5.15.3_git20211127-r4
5.15.3_git20211127-r4
alpine/qt5-qtwebengine<5.15.3_git20220121-r4
5.15.3_git20220121-r4
alpine/qt5-qtwebengine<5.15.3_git20220121-r4
5.15.3_git20220121-r4
alpine/qt5-qtwebengine<5.15.3_git20220121-r4
5.15.3_git20220121-r4
alpine/qt5-qtwebengine<5.15.3_git20220121-r4
5.15.3_git20220121-r4
alpine/qt5-qtwebengine<5.15.3_git20220121-r4
5.15.3_git20220121-r4
alpine/qt5-qtwebengine<5.15.3_git20220121-r4
5.15.3_git20220121-r4
alpine/qt5-qtwebengine<5.15.3_git20220121-r4
5.15.3_git20220121-r4
alpine/qt5-qtwebengine<5.15.3_git20220121-r4
5.15.3_git20220121-r4
debian/chromium<97.0.4692.71-0.1
97.0.4692.71-0.1
debian/chromium<97.0.4692.71-0.1
97.0.4692.71-0.1
debian/chromium<97.0.4692.71-0.1
97.0.4692.71-0.1
debian/chromium
150.0.7871.100-1~deb12u1156.0.8078.79-1~deb12u1150.0.7871.181-1~deb13u1156.0.8078.79-1~deb13u1156.0.8078.79-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade Google Chrome (Trace Event) to a version that resolves this vulnerability.

    Fixed in 97.0.4692.71
  2. Upgrade

    Upgrade alpine/qt5-qtwebengine to a version that resolves this vulnerability.

    Fixed in 5.15.3_git20211127-r4
  3. Upgrade

    Upgrade alpine/qt5-qtwebengine to a version that resolves this vulnerability.

    Fixed in 5.15.3_git20220121-r4
  4. Upgrade

    Upgrade debian/chromium to a version that resolves this vulnerability.

    Fixed in 97.0.4692.71-0.1
  5. Upgrade

    Upgrade debian/chromium to a version that resolves this vulnerability.

    Fixed in 150.0.7871.100-1~deb12u1Fixed in 156.0.8078.79-1~deb12u1Fixed in 150.0.7871.181-1~deb13u1Fixed in 156.0.8078.79-1~deb13u1Fixed in 156.0.8078.79-1

Event History

Oct 14, 2021
CVE Published
12:00 AM
Feb 11, 2022
CVE Published
via MITRE·11:35 PM
Data Sourced
via MITRE·11:35 PM
DescriptionWeakness
Feb 12, 2022
Data Sourced
via NVD·12:15 AM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·12:15 AM
DescriptionSeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Frequently Asked Questions

1

What is CVE-2022-0102?

CVE-2022-0102 is a vulnerability in V8 in Google Chrome that allows a remote attacker to potentially exploit heap corruption via a crafted HTML page.

2

What is the severity of CVE-2022-0102?

The severity of CVE-2022-0102 is not mentioned in the provided information.

3

Which software versions are affected by CVE-2022-0102?

CVE-2022-0102 affects versions of Google Chrome prior to 97.0.4692.71.

4

How can CVE-2022-0102 be fixed?

To fix CVE-2022-0102, update Google Chrome to version 97.0.4692.71 or later.

5

Where can I find more information about CVE-2022-0102?

You can find more information about CVE-2022-0102 at the following link: [CVE-2022-0102](https://security-tracker.debian.org/tracker/CVE-2022-0102).

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203