CVE-2022-0117: Policy bypass in Service Workers
Policy bypass in Blink in Google Chrome prior to 97.0.4692.71 allowed a remote attacker to leak cross-origin data via a crafted HTML page.
Credit
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
Google Chrome (Trace Event)to a version that resolves this vulnerability.Fixed in 97.0.4692.71 - Upgrade
Upgrade
alpine/qt5-qtwebengineto a version that resolves this vulnerability.Fixed in 5.15.3_git20211127-r4 - Upgrade
Upgrade
alpine/qt5-qtwebengineto a version that resolves this vulnerability.Fixed in 5.15.3_git20220121-r4 - Upgrade
Upgrade
debian/chromiumto a version that resolves this vulnerability.Fixed in 97.0.4692.71-0.1 - Upgrade
Upgrade
debian/chromiumto a version that resolves this vulnerability.Fixed in 150.0.7871.100-1~deb12u1Fixed in 156.0.8078.79-1~deb12u1Fixed in 150.0.7871.181-1~deb13u1Fixed in 156.0.8078.79-1~deb13u1Fixed in 156.0.8078.79-1
Event History
Peer vulnerabilities
Found alongside the following vulnerabilities.
- CVE-2022-0096
- CVE-2022-0097
- CVE-2022-0098
- CVE-2022-0099
- CVE-2022-0100
- CVE-2022-0101
- CVE-2022-0337
- CVE-2022-0102
- CVE-2022-0103
- CVE-2022-4924
- CVE-2022-0104
- CVE-2022-0105
- CVE-2022-0106
- CVE-2022-0107
- CVE-2022-0108
- CVE-2022-0109
- CVE-2022-0110
- CVE-2022-0111
- CVE-2022-0112
- CVE-2022-0113
- CVE-2022-0114
- CVE-2022-0115
- CVE-2022-0116
- CVE-2022-0118
- CVE-2022-0120
- CVE-2022-4925
Frequently Asked Questions
What is the severity of CVE-2022-0117?
CVE-2022-0117 is considered a medium severity vulnerability that allows cross-origin data leakage.
How do I fix CVE-2022-0117?
To fix CVE-2022-0117, update Google Chrome to version 97.0.4692.71 or later.
Who is affected by CVE-2022-0117?
CVE-2022-0117 affects versions of Google Chrome prior to 97.0.4692.71 and specific versions of Chromium on Debian.
What causes CVE-2022-0117?
CVE-2022-0117 is caused by a policy bypass in the Blink rendering engine in Google Chrome.
How was CVE-2022-0117 discovered?
CVE-2022-0117 was discovered as a result of vulnerability reporting and analysis by security researchers.