CVE-2022-0116: Inappropriate implementation in Compositing

Published Nov 20, 2021
·
Updated

Inappropriate implementation in Compositing in Google Chrome prior to 97.0.4692.71 allowed a remote attacker to spoof the contents of the Omnibox (URL bar) via a crafted HTML page.

Credit

Irvan Kurniawan (sourc7)

Affected Software

18 affected componentsFixes available
Google Chrome<97.0.4692.71
97.0.4692.71
Google Chrome<97.0.4692.71
Fedoraproject Fedora=34
Fedoraproject Fedora=35
Fedoraproject Fedora=36
alpine/qt5-qtwebengine<5.15.3_git20211127-r4
5.15.3_git20211127-r4
alpine/qt5-qtwebengine<5.15.3_git20220121-r4
5.15.3_git20220121-r4
alpine/qt5-qtwebengine<5.15.3_git20220121-r4
5.15.3_git20220121-r4
alpine/qt5-qtwebengine<5.15.3_git20220121-r4
5.15.3_git20220121-r4
alpine/qt5-qtwebengine<5.15.3_git20220121-r4
5.15.3_git20220121-r4
alpine/qt5-qtwebengine<5.15.3_git20220121-r4
5.15.3_git20220121-r4
alpine/qt5-qtwebengine<5.15.3_git20220121-r4
5.15.3_git20220121-r4
alpine/qt5-qtwebengine<5.15.3_git20220121-r4
5.15.3_git20220121-r4
alpine/qt5-qtwebengine<5.15.3_git20220121-r4
5.15.3_git20220121-r4
debian/chromium<97.0.4692.71-0.1
97.0.4692.71-0.1
debian/chromium<97.0.4692.71-0.1
97.0.4692.71-0.1
debian/chromium<97.0.4692.71-0.1
97.0.4692.71-0.1
debian/chromium
150.0.7871.100-1~deb12u1156.0.8078.79-1~deb12u1150.0.7871.181-1~deb13u1156.0.8078.79-1~deb13u1156.0.8078.79-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade Google Chrome (Trace Event) to a version that resolves this vulnerability.

    Fixed in 97.0.4692.71
  2. Upgrade

    Upgrade alpine/qt5-qtwebengine to a version that resolves this vulnerability.

    Fixed in 5.15.3_git20211127-r4
  3. Upgrade

    Upgrade alpine/qt5-qtwebengine to a version that resolves this vulnerability.

    Fixed in 5.15.3_git20220121-r4
  4. Upgrade

    Upgrade debian/chromium to a version that resolves this vulnerability.

    Fixed in 97.0.4692.71-0.1
  5. Upgrade

    Upgrade debian/chromium to a version that resolves this vulnerability.

    Fixed in 150.0.7871.100-1~deb12u1Fixed in 156.0.8078.79-1~deb12u1Fixed in 150.0.7871.181-1~deb13u1Fixed in 156.0.8078.79-1~deb13u1Fixed in 156.0.8078.79-1

Event History

Nov 20, 2021
CVE Published
12:00 AM
Feb 11, 2022
CVE Published
via MITRE·11:36 PM
Data Sourced
via MITRE·11:36 PM
DescriptionWeakness
Feb 12, 2022
Data Sourced
via NVD·12:15 AM
RemedyDescriptionSeverityAffected Software
Data Sourced
via OSV·12:15 AM
DescriptionSeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Frequently Asked Questions

1

What is the severity of CVE-2022-0116?

CVE-2022-0116 has been classified as a high severity vulnerability.

2

How do I fix CVE-2022-0116?

To mitigate CVE-2022-0116, update Google Chrome to version 97.0.4692.71 or later.

3

What does CVE-2022-0116 allow an attacker to do?

CVE-2022-0116 allows a remote attacker to spoof the contents of the Omnibox in Google Chrome.

4

Which versions of Google Chrome are affected by CVE-2022-0116?

CVE-2022-0116 affects Google Chrome versions prior to 97.0.4692.71.

5

Could CVE-2022-0116 affect my web browsing security?

Yes, CVE-2022-0116 could compromise web browsing security by allowing spoofing of URLs, leading to potential phishing risks.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203