CVE-2019-5805: Use after free in PDFium
Use-after-free in PDFium in Google Chrome prior to 74.0.3729.108 allowed a remote attacker to potentially exploit heap corruption via a crafted PDF file.
Credit
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
Google Chrome (Trace Event)to a version that resolves this vulnerability.Fixed in 74.0.3729.108 - Upgrade
Upgrade
debian/chromiumto a version that resolves this vulnerability.Fixed in 150.0.7871.100-1~deb12u1Fixed in 156.0.8078.73-1~deb12u1Fixed in 150.0.7871.181-1~deb13u1Fixed in 156.0.8078.73-1~deb13u1Fixed in 156.0.8078.47-1Fixed in 156.0.8078.79-1
Event History
Peer vulnerabilities
Found alongside the following vulnerabilities.
Frequently Asked Questions
What is the severity of CVE-2019-5805?
CVE-2019-5805 has a high severity rating as it involves a use-after-free vulnerability in PDFium that may lead to heap corruption.
How do I fix CVE-2019-5805?
To fix CVE-2019-5805, upgrade Google Chrome to version 74.0.3729.108 or later.
Which versions of Google Chrome are affected by CVE-2019-5805?
CVE-2019-5805 affects Google Chrome versions prior to 74.0.3729.108.
Can PDF files exploit CVE-2019-5805?
Yes, crafted PDF files can potentially exploit CVE-2019-5805 to cause heap corruption.
What types of systems are affected by CVE-2019-5805?
CVE-2019-5805 affects various operating systems including Debian, Fedora, and openSUSE that run vulnerable versions of Google Chrome.