CVE-2019-5820: Integer overflow in PDFium
Integer overflow in PDFium in Google Chrome prior to 74.0.3729.108 allowed a remote attacker to potentially exploit heap corruption via a crafted PDF file.
Credit
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
Google Chrome (Trace Event)to a version that resolves this vulnerability.Fixed in 74.0.3729.108 - Upgrade
Upgrade
debian/chromiumto a version that resolves this vulnerability.Fixed in 150.0.7871.100-1~deb12u1Fixed in 156.0.8078.73-1~deb12u1Fixed in 150.0.7871.181-1~deb13u1Fixed in 156.0.8078.73-1~deb13u1Fixed in 156.0.8078.47-1Fixed in 156.0.8078.79-1
Event History
Peer vulnerabilities
Found alongside the following vulnerabilities.
Frequently Asked Questions
What is the severity of CVE-2019-5820?
CVE-2019-5820 has a high severity rating as it allows for potential remote exploitation via crafted PDF files.
How do I fix CVE-2019-5820?
To mitigate CVE-2019-5820, update Google Chrome to version 74.0.3729.108 or later.
What causes CVE-2019-5820?
CVE-2019-5820 is caused by an integer overflow vulnerability in PDFium within Google Chrome.
Which versions of Google Chrome are affected by CVE-2019-5820?
Google Chrome versions prior to 74.0.3729.108 are affected by CVE-2019-5820.
Can CVE-2019-5820 affect PDF files from untrusted sources?
Yes, CVE-2019-5820 can be exploited using specially crafted PDF files, which makes it risky to open PDFs from untrusted sources.