CVE-2019-5807: Memory corruption in V8
Object lifetime issue in V8 in Google Chrome prior to 74.0.3729.108 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page.
Credit
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
Google Chrome (Trace Event)to a version that resolves this vulnerability.Fixed in 74.0.3729.108 - Upgrade
Upgrade
debian/chromiumto a version that resolves this vulnerability.Fixed in 150.0.7871.100-1~deb12u1Fixed in 156.0.8078.73-1~deb12u1Fixed in 150.0.7871.181-1~deb13u1Fixed in 156.0.8078.73-1~deb13u1Fixed in 156.0.8078.47-1Fixed in 156.0.8078.79-1
Event History
Peer vulnerabilities
Found alongside the following vulnerabilities.
Frequently Asked Questions
What is the severity of CVE-2019-5807?
CVE-2019-5807 is classified as a high-severity vulnerability that can lead to heap corruption in Google Chrome.
How do I fix CVE-2019-5807?
To fix CVE-2019-5807, update Google Chrome to version 74.0.3729.108 or later.
Which versions of Google Chrome are affected by CVE-2019-5807?
CVE-2019-5807 affects all versions of Google Chrome prior to 74.0.3729.108.
Does CVE-2019-5807 affect Chromium on Debian?
Yes, CVE-2019-5807 affects certain versions of Chromium on Debian that are lower than 74.0.3729.108.
What platforms are impacted by CVE-2019-5807?
CVE-2019-5807 impacts Google Chrome, Chromium on Debian, and various versions of Fedora and openSUSE.