CVE-2019-5811: CORS bypass in Blink
Incorrect handling of CORS in ServiceWorker in Google Chrome prior to 74.0.3729.108 allowed a remote attacker to bypass same origin policy via a crafted HTML page.
Credit
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
Google Chrome (Trace Event)to a version that resolves this vulnerability.Fixed in 74.0.3729.108 - Upgrade
Upgrade
debian/chromiumto a version that resolves this vulnerability.Fixed in 150.0.7871.100-1~deb12u1Fixed in 156.0.8078.73-1~deb12u1Fixed in 150.0.7871.181-1~deb13u1Fixed in 156.0.8078.73-1~deb13u1Fixed in 156.0.8078.47-1Fixed in 156.0.8078.79-1
Event History
Peer vulnerabilities
Found alongside the following vulnerabilities.
Frequently Asked Questions
What is the severity of CVE-2019-5811?
CVE-2019-5811 has a high severity rating due to its potential to bypass the same origin policy.
How do I fix CVE-2019-5811?
To fix CVE-2019-5811, update Google Chrome to version 74.0.3729.108 or later.
Which versions of Google Chrome are affected by CVE-2019-5811?
Google Chrome versions prior to 74.0.3729.108 are affected by CVE-2019-5811.
What type of vulnerability is CVE-2019-5811?
CVE-2019-5811 is an incorrect handling of CORS vulnerability in ServiceWorker.
Can CVE-2019-5811 affect other software apart from Google Chrome?
Yes, CVE-2019-5811 can also affect Chromium running on various operating systems, including Debian and Fedora.