CVE-2019-5823: Medium severity Google Chrome vulnerability
Insufficient policy enforcement in service workers in Google Chrome prior to 74.0.3729.108 allowed a remote attacker to bypass navigation restrictions via a crafted HTML page.
Credit
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
Google Chrome (Trace Event)to a version that resolves this vulnerability.Fixed in 74.0.3729.108 - Upgrade
Upgrade
debian/chromiumto a version that resolves this vulnerability.Fixed in 150.0.7871.100-1~deb12u1Fixed in 156.0.8078.73-1~deb12u1Fixed in 150.0.7871.181-1~deb13u1Fixed in 156.0.8078.73-1~deb13u1Fixed in 156.0.8078.47-1Fixed in 156.0.8078.79-1 - Upgrade
Upgrade
Google Chrometo a version that resolves this vulnerability.Fixed in 74.0.3729.108
Event History
Peer vulnerabilities
Found alongside the following vulnerabilities.
Frequently Asked Questions
What is the severity of CVE-2019-5823?
CVE-2019-5823 is classified as a high-severity vulnerability due to its ability to allow remote attackers to bypass navigation restrictions in Google Chrome.
How do I fix CVE-2019-5823?
To fix CVE-2019-5823, users should update Google Chrome to version 74.0.3729.108 or later.
Which versions of Google Chrome are affected by CVE-2019-5823?
Google Chrome versions prior to 74.0.3729.108 are affected by CVE-2019-5823.
Is CVE-2019-5823 exploitable in service workers?
Yes, CVE-2019-5823 specifically affects the enforcement of policies in service workers.
Can CVE-2019-5823 impact user security?
Yes, CVE-2019-5823 can impact user security by allowing attackers to navigate users to unintended content or malicious sites.