CVE-2019-5821: Integer overflow in PDFium
Integer overflow in PDFium in Google Chrome prior to 74.0.3729.108 allowed a remote attacker to potentially exploit heap corruption via a crafted PDF file.
Credit
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
Google Chrome (Trace Event)to a version that resolves this vulnerability.Fixed in 74.0.3729.108 - Upgrade
Upgrade
debian/chromiumto a version that resolves this vulnerability.Fixed in 150.0.7871.100-1~deb12u1Fixed in 156.0.8078.73-1~deb12u1Fixed in 150.0.7871.181-1~deb13u1Fixed in 156.0.8078.73-1~deb13u1Fixed in 156.0.8078.47-1Fixed in 156.0.8078.79-1
Event History
Peer vulnerabilities
Found alongside the following vulnerabilities.
Frequently Asked Questions
What is the severity of CVE-2019-5821?
CVE-2019-5821 is classified as a high severity vulnerability due to its potential for remote exploitation and heap corruption.
How do I fix CVE-2019-5821?
To fix CVE-2019-5821, update Google Chrome to version 74.0.3729.108 or later as soon as possible.
What impacts does CVE-2019-5821 have on affected software?
CVE-2019-5821 allows remote attackers to exploit heap corruption by using a crafted PDF file.
Which versions of Google Chrome are affected by CVE-2019-5821?
Versions of Google Chrome prior to 74.0.3729.108 are affected by CVE-2019-5821.
Are any Linux distributions impacted by CVE-2019-5821?
Yes, CVE-2019-5821 impacts various Linux distributions including Debian, openSUSE, and Fedora in specific versions.