CVE-2019-5810: User information disclosure in Autofill
Information leak in autofill in Google Chrome prior to 74.0.3729.108 allowed a remote attacker to obtain potentially sensitive information from process memory via a crafted HTML page.
Credit
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
Google Chrome (Trace Event)to a version that resolves this vulnerability.Fixed in 74.0.3729.108 - Upgrade
Upgrade
debian/chromiumto a version that resolves this vulnerability.Fixed in 150.0.7871.100-1~deb12u1Fixed in 156.0.8078.73-1~deb12u1Fixed in 150.0.7871.181-1~deb13u1Fixed in 156.0.8078.73-1~deb13u1Fixed in 156.0.8078.47-1Fixed in 156.0.8078.79-1
Event History
Peer vulnerabilities
Found alongside the following vulnerabilities.
Frequently Asked Questions
What is the severity of CVE-2019-5810?
CVE-2019-5810 is classified as a medium severity vulnerability due to its potential for information leakage from process memory.
How do I fix CVE-2019-5810?
To fix CVE-2019-5810, update Google Chrome to version 74.0.3729.108 or later, or ensure that your Chromium version is up to date with the specified fixes.
Which versions of Google Chrome are affected by CVE-2019-5810?
CVE-2019-5810 affects all versions of Google Chrome prior to 74.0.3729.108.
What type of attack does CVE-2019-5810 enable?
CVE-2019-5810 enables a remote attacker to obtain potentially sensitive information from the process memory via a crafted HTML page.
Is there a workaround for CVE-2019-5810?
There are no known workarounds for CVE-2019-5810, so the best mitigation is to update to a newer version of the affected software.