CVE-2021-4054: Incorrect security UI in autofill
Incorrect security UI in autofill in Google Chrome prior to 96.0.4664.93 allowed a remote attacker to perform domain spoofing via a crafted HTML page.
Credit
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
Google Chrome (Trace Event)to a version that resolves this vulnerability.Fixed in 96.0.4664.93 - Upgrade
Upgrade
debian/chromiumto a version that resolves this vulnerability.Fixed in 150.0.7871.100-1~deb12u1Fixed in 156.0.8078.79-1~deb12u1Fixed in 150.0.7871.181-1~deb13u1Fixed in 156.0.8078.79-1~deb13u1Fixed in 156.0.8078.79-1
Event History
Peer vulnerabilities
Found alongside the following vulnerabilities.
Frequently Asked Questions
What is the severity of CVE-2021-4054?
CVE-2021-4054 has been classified as a medium severity vulnerability.
How do I fix CVE-2021-4054?
To fix CVE-2021-4054, update Google Chrome to version 96.0.4664.93 or later.
What systems are affected by CVE-2021-4054?
CVE-2021-4054 affects Google Chrome versions prior to 96.0.4664.93 and certain versions of Debian and Fedora.
What is the impact of CVE-2021-4054?
CVE-2021-4054 allows remote attackers to perform domain spoofing through a crafted HTML page.
Is there a workaround for CVE-2021-4054?
There is no official workaround for CVE-2021-4054; the best solution is to update to the latest version of the browser.