CVE-2021-4058: Heap buffer overflow in ANGLE

Published Nov 6, 2021
·
Updated

Heap buffer overflow in ANGLE in Google Chrome prior to 96.0.4664.93 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page.

Credit

Abraruddin Khan, Omair

Affected Software

16 affected componentsFixes available
Google Chrome<96.0.4664.93
96.0.4664.93
Google Chrome<96.0.4664.93
Fedoraproject Fedora=34
Debian Debian Linux=10.0
Debian Debian Linux=11.0
alpine/qt5-qtwebengine<5.15.3_git20211112-r1
5.15.3_git20211112-r1
alpine/qt5-qtwebengine<5.15.3_git20211127-r1
5.15.3_git20211127-r1
alpine/qt5-qtwebengine<5.15.3_git20211127-r1
5.15.3_git20211127-r1
alpine/qt5-qtwebengine<5.15.3_git20211127-r1
5.15.3_git20211127-r1
alpine/qt5-qtwebengine<5.15.3_git20211127-r1
5.15.3_git20211127-r1
alpine/qt5-qtwebengine<5.15.3_git20211127-r1
5.15.3_git20211127-r1
alpine/qt5-qtwebengine<5.15.3_git20211127-r1
5.15.3_git20211127-r1
alpine/qt5-qtwebengine<5.15.3_git20211127-r1
5.15.3_git20211127-r1
alpine/qt5-qtwebengine<5.15.3_git20211127-r1
5.15.3_git20211127-r1
alpine/qt5-qtwebengine<5.15.3_git20211127-r1
5.15.3_git20211127-r1
debian/chromium
150.0.7871.100-1~deb12u1156.0.8078.79-1~deb12u1150.0.7871.181-1~deb13u1156.0.8078.79-1~deb13u1156.0.8078.79-1

Remediation

Recommended actions to resolve this vulnerability, in priority order.

  1. Upgrade

    Upgrade Google Chrome (Trace Event) to a version that resolves this vulnerability.

    Fixed in 96.0.4664.93
  2. Upgrade

    Upgrade alpine/qt5-qtwebengine to a version that resolves this vulnerability.

    Fixed in 5.15.3_git20211112-r1
  3. Upgrade

    Upgrade alpine/qt5-qtwebengine to a version that resolves this vulnerability.

    Fixed in 5.15.3_git20211127-r1
  4. Upgrade

    Upgrade debian/chromium to a version that resolves this vulnerability.

    Fixed in 150.0.7871.100-1~deb12u1Fixed in 156.0.8078.79-1~deb12u1Fixed in 150.0.7871.181-1~deb13u1Fixed in 156.0.8078.79-1~deb13u1Fixed in 156.0.8078.79-1

Event History

Nov 6, 2021
CVE Published
12:00 AM
Dec 23, 2021
CVE Published
via MITRE·12:45 AM
Data Sourced
via MITRE·12:45 AM
DescriptionWeakness
Data Sourced
via NVD·01:15 AM
DescriptionSeverityWeaknessAffected Software
Data Sourced
via OSV·01:15 AM
DescriptionSeverityAffected Software

Parent advisories

This vulnerability appears in the following advisories.

Frequently Asked Questions

1

What is the severity of CVE-2021-4058?

CVE-2021-4058 is classified as a high severity vulnerability due to the potential for arbitrary code execution resulting from a heap buffer overflow.

2

How do I fix CVE-2021-4058?

To address CVE-2021-4058, update Google Chrome or Chromium to version 96.0.4664.93 or later.

3

Which versions of Chrome are affected by CVE-2021-4058?

CVE-2021-4058 affects Google Chrome versions prior to 96.0.4664.93.

4

What systems are vulnerable to CVE-2021-4058?

CVE-2021-4058 impacts systems running vulnerable versions of Google Chrome and specific Debian distributions.

5

Can CVE-2021-4058 be exploited remotely?

Yes, CVE-2021-4058 can potentially be exploited remotely via a crafted HTML page.

Contact

SecAlerts Pty Ltd.
132 Wickham Terrace
Fortitude Valley,
QLD 4006, Australia
info@secalerts.co
By using SecAlerts services, you agree to our services end-user license agreement. This website is safeguarded by reCAPTCHA and governed by the Google Privacy Policy and Terms of Service. All names, logos, and brands of products are owned by their respective owners, and any usage of these names, logos, and brands for identification purposes only does not imply endorsement. If you possess any content that requires removal, please get in touch with us.
© 2026 SecAlerts Pty Ltd.
ABN: 70 645 966 203, ACN: 645 966 203