CVE-2021-4062: Heap buffer overflow in BFCache
Heap buffer overflow in BFCache in Google Chrome prior to 96.0.4664.93 allowed a remote attacker who had compromised the renderer process to potentially exploit heap corruption via a crafted HTML page.
Credit
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
Google Chrome (Trace Event)to a version that resolves this vulnerability.Fixed in 96.0.4664.93 - Upgrade
Upgrade
alpine/qt5-qtwebengineto a version that resolves this vulnerability.Fixed in 5.15.3_git20211112-r1 - Upgrade
Upgrade
alpine/qt5-qtwebengineto a version that resolves this vulnerability.Fixed in 5.15.3_git20211127-r1 - Upgrade
Upgrade
debian/chromiumto a version that resolves this vulnerability.Fixed in 150.0.7871.100-1~deb12u1Fixed in 156.0.8078.79-1~deb12u1Fixed in 150.0.7871.181-1~deb13u1Fixed in 156.0.8078.79-1~deb13u1Fixed in 156.0.8078.79-1
Event History
Peer vulnerabilities
Found alongside the following vulnerabilities.
Frequently Asked Questions
What is the severity of CVE-2021-4062?
CVE-2021-4062 has a severity rating of high due to the potential for heap corruption that could be exploited by attackers.
How do I fix CVE-2021-4062?
To fix CVE-2021-4062, update Google Chrome to version 96.0.4664.93 or later.
What applications are affected by CVE-2021-4062?
CVE-2021-4062 affects Google Chrome versions prior to 96.0.4664.93 and certain versions of Chromium on Debian.
Can CVE-2021-4062 lead to remote code execution?
Yes, CVE-2021-4062 can potentially allow remote code execution due to heap buffer overflow.
Is there a workaround for CVE-2021-4062?
There are no known workarounds for CVE-2021-4062, so updating to the latest version is recommended.