CVE-2021-4056: Type Confusion in loader
Type confusion in loader in Google Chrome prior to 96.0.4664.93 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page.
Credit
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
Google Chrome (Trace Event)to a version that resolves this vulnerability.Fixed in 96.0.4664.93 - Upgrade
Upgrade
debian/chromiumto a version that resolves this vulnerability.Fixed in 150.0.7871.100-1~deb12u1Fixed in 156.0.8078.79-1~deb12u1Fixed in 150.0.7871.181-1~deb13u1Fixed in 156.0.8078.79-1~deb13u1Fixed in 156.0.8078.79-1
Event History
Peer vulnerabilities
Found alongside the following vulnerabilities.
Frequently Asked Questions
What is the severity of CVE-2021-4056?
CVE-2021-4056 has a high severity rating as it allows for potential heap corruption exploitation.
How do I fix CVE-2021-4056?
To fix CVE-2021-4056, update Google Chrome or Chromium to version 96.0.4664.93 or later.
Which versions of Google Chrome are affected by CVE-2021-4056?
CVE-2021-4056 affects Google Chrome versions before 96.0.4664.93.
Can CVE-2021-4056 be exploited by a remote attacker?
Yes, CVE-2021-4056 can potentially be exploited by a remote attacker through a crafted HTML page.
Are any Linux distributions affected by CVE-2021-4056?
Yes, Debian and Fedora Linux distributions with affected versions of Chromium or Chrome are at risk from CVE-2021-4056.