CVE-2021-4057: Use after free in file API
Use after free in file API in Google Chrome prior to 96.0.4664.93 allowed a remote attacker who had compromised the renderer process to potentially exploit heap corruption via a crafted HTML page.
Credit
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
Google Chrome (Trace Event)to a version that resolves this vulnerability.Fixed in 96.0.4664.93 - Upgrade
Upgrade
alpine/qt5-qtwebengineto a version that resolves this vulnerability.Fixed in 5.15.3_git20211112-r1 - Upgrade
Upgrade
alpine/qt5-qtwebengineto a version that resolves this vulnerability.Fixed in 5.15.3_git20211127-r1 - Upgrade
Upgrade
debian/chromiumto a version that resolves this vulnerability.Fixed in 150.0.7871.100-1~deb12u1Fixed in 156.0.8078.79-1~deb12u1Fixed in 150.0.7871.181-1~deb13u1Fixed in 156.0.8078.79-1~deb13u1Fixed in 156.0.8078.79-1
Event History
Peer vulnerabilities
Found alongside the following vulnerabilities.
Frequently Asked Questions
What is the severity of CVE-2021-4057?
CVE-2021-4057 has a medium severity rating as it allows potential heap corruption due to a use after free vulnerability.
How do I fix CVE-2021-4057?
To fix CVE-2021-4057, update Google Chrome to version 96.0.4664.93 or later.
Which versions of Chrome are affected by CVE-2021-4057?
All versions of Google Chrome prior to 96.0.4664.93 are affected by CVE-2021-4057.
Is CVE-2021-4057 specific to any operating system?
CVE-2021-4057 affects multiple operating systems, including Debian and Fedora, that run vulnerable versions of Google Chrome.
Can CVE-2021-4057 be exploited remotely?
Yes, CVE-2021-4057 allows a remote attacker to potentially exploit the vulnerability through a crafted HTML page.