CVE-2021-4059: Insufficient data validation in loader
Insufficient data validation in loader in Google Chrome prior to 96.0.4664.93 allowed a remote attacker to leak cross-origin data via a crafted HTML page.
Credit
Affected Software
Remediation
Recommended actions to resolve this vulnerability, in priority order.
- Upgrade
Upgrade
Google Chrome (Trace Event)to a version that resolves this vulnerability.Fixed in 96.0.4664.93 - Upgrade
Upgrade
alpine/qt5-qtwebengineto a version that resolves this vulnerability.Fixed in 5.15.3_git20211112-r1 - Upgrade
Upgrade
alpine/qt5-qtwebengineto a version that resolves this vulnerability.Fixed in 5.15.3_git20211127-r1 - Upgrade
Upgrade
debian/chromiumto a version that resolves this vulnerability.Fixed in 150.0.7871.100-1~deb12u1Fixed in 156.0.8078.79-1~deb12u1Fixed in 150.0.7871.181-1~deb13u1Fixed in 156.0.8078.79-1~deb13u1Fixed in 156.0.8078.79-1
Event History
Peer vulnerabilities
Found alongside the following vulnerabilities.
Frequently Asked Questions
What is the severity of CVE-2021-4059?
CVE-2021-4059 has been classified as a high-severity vulnerability.
How do I fix CVE-2021-4059?
To mitigate CVE-2021-4059, upgrade to Google Chrome version 96.0.4664.93 or later.
What software is affected by CVE-2021-4059?
CVE-2021-4059 affects Google Chrome versions prior to 96.0.4664.93 and various versions of Chromium on Debian and Fedora.
What type of vulnerability is CVE-2021-4059?
CVE-2021-4059 is characterized as an insufficient data validation vulnerability.
Can CVE-2021-4059 be exploited remotely?
Yes, CVE-2021-4059 can be exploited by remote attackers through a crafted HTML page.